In this section each menu item in the GNOME File Manager will be described.
Tip: All menus in the GNOME File Manager are enabled with the tear-away
feature. If you would like any menu to "float" on the desktop in its own
window simply select the perforation line at the top of the menu.
File - The File Menu contains items associated with
files and higher level activity.
Create New Window - This will open a new File
Manager Window.
New | Terminal - This launches a new GNOME
Terminal window that will automatically navigate to the directory
displayed in the main window view.
New | Directory - This creates a new
directory in the directory displayed in the main window view.
New | [application] - Some applications may
put items for you in the New menu. For example, the
Gnumeric spreadsheet will put a New Gnumeric
Spreadsheet menu item in the New menu
so you can a new spreadsheet in the directory diplayed in the main
window view.
Open - This will open the file you have
selected with your mouse cursor.
Copy - This will launch the Copy dialog to
enable you to copy the selected file to a destination you choose.
Delete - This will delete the file you have
selected.
Move - This will launch the Move/rename
dialog to enable you to rename the selected file or move it to a
destination you choose.
Show directory sizes - This option will
determine the size of your directories and display it in the Detail or
Custom views. Depending on the size of your directories, this could
take a while to display and may tax your system when viewing large
directories.
Close this Window - This will close the GNOME
File Manager window you are currently running.
Edit - The Edit menu contains items that are associated
with editing and selecting files.
Select All - This will select all of the
files in the main window.
Select Files - This will launch a simple
dialog box which will allow you to specify a selection pattern. For
Example, if you wish to select all files beginning with the letter D you
can simple type D* and press OK.
Invert Selection - This will invert the
current selection. For example, if you have 7 files selected in a
directory with 10 files, selecting Invert Selection will select the
three remaining files and unselect the 7 files that were previously
selected.
Search - This toggles on the "completion"
search for the Flie Manager. Once it is turned on the status bar at the
bottom of the window displays the word "Search:" and allows you to start
typing. If you are searching for a file named "GNU" in the directory
displayed in the main window view typing "G" will move the selection to
the first file or directory beginning with "G". Typing "GN" move the
selection to the first file beginning with "GN", and so on. You may also
toggle this feature on by pressing
CTRL-S.To end the
search you may select the file or directory or simply navigate away from
the file with the arrow keys or your mouse.
Rescan Directory - This will rescan the
current directory in case the files in the directory have changed.
Settings - This contains the Preferences menu item.
Preferences - This will launch the
Preferences dialog so that you can customize the GNOME File Manager.
Layout - This menu contains items that are associated
with the layout in GNOME File Manager.
Sort By - This will launch a dialog box
which will allow you to select how you wish the files to be sorted in
the current directory. You may sort by one of the following:
Name
File Type
Size
Time Last Accessed
Time Last Modified
Time Last Changed
Filter View - This will bring up a simple
dialog which allows you to view only files with names matching a
pattern. For example, if you wish to only view files in the directory
that start with the letter D you can type D* into the dialog and press
OK. If you wish to see all files again you will need to launch the
Filter View dialog again and clear the dialog or type in a *.
Icon View - Selecting this will display the
files in the main window as large icons.
Partial View - Selecting this will display
the files in the main window as a list with only file names.
Full View - Selecting this will display the
files in the main window as a list with all file information.
Custom View - The Custom
View menu item switches the main window to the Custom
View which is a list view displaying the information about your files
that you specify. To customize the Custom view you will need to use
the Custom View Editor in the
Preferences dialog. You may read more about the
Preferences dialog in the section called Changing Your Preferences in The File Manager.
Commands - The Command menu contains items that are
commands to run on files in the GNOME File Manager.
Find File - Find File brings up a dialog
which allows you to search for particular files on your system.
Edit mime types - This option will launch
the GNOME Control Center Capplet that allows you to edit Mime Types for
GNOME. Mime types determine, among other things, what application will
handle particular file types. You can read more about mime types in
the section called GNOME Mime Types in Chapter 17
Run Command - This menu item allows you to
run a command from GMC.
Run Command in panel - This menu item lets
you run preloaded commands or commands you specify within the directory
that you are currently in. Such commands might be to find SUID or SGID
programs, etc.
Exit - This will allow you to exit the GNOME
File Manager.
IMPORTANT: This will exit all GNOME File Manager processes which include the
GNOME Desktop. If you exit you will lose all functionality on your
desktop. This action is not recommended. If you wish to close the
current window, use the File/Close button.