|
|
||
|
||
|
|
| Red Hat Documentation |
Chapitre 9. Brève introduction à GIMPLe programme GNU Image Manipulation Program (GIMP) peut vous aider à créer, modifier, manipuler ou améliorer des fichiers image numériques (photographies, images numérisées, images générées par ordinateur, etc.). Ce chapitre a pour but de vous donner un aperçu rapide de GIMP et de ses applications les plus courantes. Comme d'autres domaines d'activité, la manipulation d'images a son propre vocabulaire. Ce chapitre ne peut pas fournir une présentation exhaustive de tous les termes et concepts nécessaires à une compréhension totale de GIMP. Pour en savoir plus, plusieurs livres traitent de GIMP et de ses fonctions, de même que des concepts sous-jacents à la manipulation d'images. Reportez-vous à la la section intitulée Sources d'informations complémentaires pour plus d'informations sur GIMP. Comme vous ne tarderez pas à le constater si vous essayez GIMP, celui-ci comprend une mine d'outils pour l'édition d'images (bien plus qu'il n'est possible d'en décrire dans un seul chapitre). De plus, si vous ne parvenez pas à créer l'effet adéquat avec les outils fournis par GIMP, et si vous ne craignez pas de lire des scripts dans le langage de script Scheme, vous pouvez ajouter un nouveau Script-Fu à GIMP. Un Script-Fu est comparable à une macro d'application de traitement de texte ou de tableur ; il applique une série déterminée d'effets (filtres ou autres fonctions de GIMP) à un graphique ou un élément de texte. N'importe qui peut utiliser les programmes script-Fu inclus dans Gimp, mais rien ne vous empêche d'écrire le vôtre. Reportez-vous à la la section intitulée Sources d'informations complémentaires pour trouver plus de sources d'informations sur les programmes Script-Fu. GIMP permet de faire bien des choses, mais il connaît néanmoins certaines limites. Les graphistes qui créent des images pour la presse écrite trouvent GIMP lacunaire ou plus difficile à utiliser pour les applications de PAO. Par exemple, GIMP ne peut pas (encore) fonctionner dans un environnement couleur CMJN (cyan, magenta, jaune et noir), généralement utilisé pour l'impression de graphiques couleur. GIMP utilise l'environnement couleur RVB (rouge, vert et bleu), auquel sont habituées les personnes créant des éléments graphiques pour le Web. Du fait que GIMP est bien adapté à la création d'éléments graphiques pour le Web, c'est cet aspect que nous allons aborder dans le cadre de ce chapitre. Tout d'abord, nous allons éditer une photo à afficher sur une page Web. Ensuite, nous allons créer une image de fond qui sera utilisée sous forme de mosaïque pour composer le fond de notre page Web. Enfin, nous allons utiliser GIMP afin de créer une image de titre pour la page Web. Avant de vous lancer dans la pratique, vous devez avoir assimilé un certain nombre de rudiments : création de fichiers, enregistrement de fichiers, boîte à outils et boîtes de dialogue. Rudiments de GIMPPour pouvoir utiliser GIMP, vous devez connaître un certain nombre d'éléments de base. Depuis une fenêtre Xterm, vous pouvez lancer GIMP à l'aide de la commande gimp. Comme de nombreuses applications, GIMP offre plusieurs méthodes d'accomplissement d'une même tâche. Généralement, il y a trois manières de travailler dans GIMP :
Lorsque vous lancez GIMP, le système affiche la boîte à outils. Boîte à outilsLa boîte à outils de GIMP est une palette d'outils de GIMP couramment utilisés : Vous pouvez réduire la boîte à outils (la placer dans le tableau de bord). Sachez que si vous la fermez, vous fermez GIMP en même temps. Si vous déplacez la souris sur les boutons de la boîte à outils, une boîte de dialogue contextuelle s'affiche pour indiquer la fonction de l'outil. Cliquez sur le bouton correspondant à l'outil que vous voulez utiliser. Le bouton apparaît alors coloré, indiquant que l'outil est actif. Généralement, vous utiliserez un outil pour une image en activant l'outil, puis en cliquant et en le faisant glisser sur l'image. Si une partie de l'image est sélectionnée, l'outil ne fonctionne que sur la partie sélectionnée. Les sélections sont identifiées par une bordure mobile en pointillés. De nombreux outils comprennent des options. Un double-clic sur le bouton d'un outil affiche la boîte de dialogue Tool Options correspondant à cet outil. Outils de la boîte à outils
CouleursAu bas de la boîte à outils s'affichent les couleurs actives : Le carré de la couleur active apparaît enfoncé ; vous pouvez voir à la Figure 9-2 que le carré de la couleur d'avant-plan noir est celui de la couleur active. Par défaut, le noir est la couleur d'avant-plan active et le
blanc la couleur de fond active. Pour inverser les couleurs
d'avant-plan et de fond, cliquez sur
Cliquez sur la case de la couleur active pour afficher la boîte de dialogue Color Selection : Vous pouvez sélectionner une couleur à "main levée" en activant l'une des cases d'option pour la teinte, la saturation, la valeur (rouge, vert ou bleu), en sélectionnant une plage de couleurs dans la barre du milieu, puis une couleur spécifique dans le carré de la couleur. Vous pouvez également taper les valeurs RVB appropriées, ou la valeur hexadécimale de la couleur que vous voulez sélectionner. Lorsque vous sélectionnez des couleurs en cliquant sur le carré de couleur ou en tapant les valeurs exactes, la case de la couleur active de la boîte à outils affiche la nouvelle couleur. Les opérations de sélection de couleur sont beaucoup plus complexes que la description qui en est donnée ici. Si le sujet vous intéresse, reportez-vous aux ressources plus approfondies de la la section intitulée Sources d'informations complémentaires. Brosse, motif et dégradé actifsUn carré en bas à droite de la boîte à outils montre la brosse, le motif et le dégradé actifs : Si vous voulez sélectionner une brosse, un motif ou un dégradé différents, double-cliquez sur la brosse, le motif ou le dégradé actif afin d'afficher la palette des choix possibles pour chacun de ces éléments. Cliquez sur un choix de la palette pour en faire la brosse, le motif ou le dégradé actif. Sélection de zones d'une imageGIMP comprend six outils de sélection. Vous pouvez les utiliser en cliquant et faisant glisser le pointeur sur la portion de l'image que vous voulez sélectionner. GIMP offre également des méthodes permettant de modifier votre sélection. Ces modifications s'appliquent si votre sélection est active. Vous pouvez reconnaître une sélection active à la bordure mobile en pointillés entourant son périmètre.
Boîte de dialogue Brush SelectionPour afficher la boîte de dialogue Brush Selection, cliquez sur la brosse active dans la boîte à outils. La boîte de dialogue Brush Selection ressemble à la Figure 9-5: Lorsque vous utilisez des outils de dessin de GIMP, vous pouvez modifier les attributs de la ligne tracée en sélectionnant une brosse particulière. Cliquez sur une brosse dans la palette pour la sélectionner. Si la brosse est plus grande que le carré, cliquez sur le carré et maintenez le bouton enfoncé pour afficher la brosse toute entière. Chargement d'un fichierPour pouvoir retoucher une image, vous devez commencer par l'acquérir d'une manière ou d'une autre. Par exemple, vous pouvez numériser une image, en télécharger une sur Internet (attention aux restrictions en matière de copyright !) ou prendre une photo avec un appareil photo numérique. Pour charger un fichier existant, sélectionnez File => Open. La boîte de dialogue Load Image s'affiche, comme illustré à la Figure 9-6. La boîte de dialogue Load Image affiche le répertoire qui était votre répertoire de travail au moment où vous avez démarré GIMP. Vous pouvez naviguer vers le haut et vers le bas dans l'arborescence du système de fichiers en double-cliquant sur la liste Directories à gauche, puis en sélectionnant un fichier à ouvrir dans la liste Files à droite. La fonction permettant de compléter le nom de fichier est prise en charge par GIMP. Si vous tapez la première lettre (ou plus) d'un nom de ficher dans le champ Selection, puis appuyez sur la touche Tab, l'affichage change, ne montrant que les sous-répertoires et/ou fichiers dont le nom commence par la (ou les) lettre(s) en question. Le fichier sélectionné apparaît dans le champ Selection dans la partie inférieure de la boîte de dialogue. Une miniature s'affiche dans la boîte de dialogue ; il est également possible que vous voyiez un bouton Generate Preview. Si vous voulez voir une miniature de l'image, cliquez sur le bouton Generate Preview. Après avoir sélectionné un fichier, cliquez sur le bouton OK pour l'ouvrir. Vous pouvez également double-cliquer sur le nom d'un fichier pour l'ouvrir. Enregistrement d'un fichierPour enregistrer un fichier image, cliquez avec le bouton droit sur l'image et sélectionnez File => Save (ou Save as). La boîte de dialogue Save Image s'affiche si vous sélectionnez Save as ou Save alors que le fichier n'a pas encore été enregistré. La boîte de dialogue Save Image ressemble presque exactement à la boîte de dialogue Load Image ; la navigation dans l'arborescence du système de fichiers et le choix des fichiers fonctionnent de la même manière. Lorsque vous enregistrez une image, vous devez sélectionner le format dans lequel l'enregistrer. GIMP prend en charge un vaste éventail de formats d'image. Ce chapitre décrit trois de ces formats : .gif, .jpg et .xcf. Formats d'imageLa grande majorité des images disponibles sur le Web sont au format .gif ou au format .jpg. Les deux formats utilisent un algorithme de compression pour fournir des fichiers de plus petite taille et des temps de téléchargement plus courts (la vitesse de téléchargement est d'une importance décisive pour tout ce qui se trouve sur le Web). En revanche, dans la plupart des autres cas, ces deux formats d'image sont très différents et conviennent à des usages différents. Le format .jpg convient pour les photographies et les images utilisant de nombreuses couleurs différentes. Le format .gif convient parfaitement pour les images n'utilisant que peu de couleurs ou comprenant une surface relativement importante d'une même couleur. Pour que GIMP vous permette d'enregistrer une image au format .gif, vous devez préalablement la convertir en couleurs indexées ou en niveaux de gris. Pour convertir une image en couleurs indexées, cliquez avec le bouton droit sur l'image, puis sélectionnez Image => Mode => Indexed. La boîte de dialogue Indexed Color Conversion s'affiche : Afin de réduire au minimum la taille du fichier, une image .gif ne peut afficher plus de 256 couleurs. Lorsque vous la convertissez en couleurs indexées, les couleurs RVB de l'image sont "standardisées" par rapport à une palette de couleurs particulière. Si votre image est destinée à être utilisée sur le Web, le choix de palette le plus sûr est Use Custom Palette: Web. La palette optimisée pour le Web comprend le groupe de 216 couleurs utilisées par la majorité des navigateurs Web. Après avoir converti l'image au format couleurs indexées, GIMP vous permet de l'enregistrer comme un fichier .gif. Si vous travaillez sur une image dans GIMP et voulez l'enregistrer afin de continuer à travailler dessus plus tard, enregistrez-la comme fichier .xcf. Le format .xcf est le format de fichier natif de GIMP. Lorsque vous créez une image dans GIMP ou ouvrez une image et y ajoutez des effets GIMP (tels que des calques ou des masques), vous ajoutez des informations au fichier image. Ces informations seront perdues si vous enregistrez l'image comme fichier .gif ou .jpg. Si vous enregistrez un fichier comme fichier .xcf, vous préservez ces informations. Lorsque vous ouvrirez à nouveau le fichier .xcf, vous pourrez le modifier comme si vous ne l'aviez jamais fermé. Fenêtre d'imageLorsque vous chargez une image ou ouvrez une nouvelle image, GIMP entoure l'image d'un cadre comprenant des informations et outils utiles, comme illustré à la Figure 9-8. La partie supérieure de la fenêtre d'image comprend un identificateur de fichier comprenant :
Dans le coin supérieur gauche, si vous cliquez sur
l'icône
Pour vous aider à visualiser la taille de l'image, GIMP comprend des règles horizontale et verticale. Vous pouvez les activer et les désactiver en cliquant avec le bouton droit sur l'image, puis en sélectionnant View => Toggle Rulers. Dans le coin inférieur gauche s'inscrit la position du curseur de la souris dans l'image, mesurée à partir de 0,0 (dans le coin supérieur gauche). Juste au-dessus de la zone indiquant la position du curseur de la souris figurent deux icônes carrées permettant de créer des masques rapides. Fondamentalement, les masques sont des sélections qu'il est possible d'enregistrer et de réutiliser. Nous n'évoquerons pas les masques dans ce chapitre. Toutefois, si vous utilisez GIMP pour traiter des images complexes, les masques vous sembleront certainement très pratiques. Consultez certaines sources indiquées dans la la section intitulée Sources d'informations complémentaires pour plus d'informations sur les masques. Près du coin inférieur droit figure une icône ressemblant à celle de l'outil de déplacement. On l'appelle le panoramique. Si vous avez fait un agrandissement de l'image, vous pouvez cliquer sur le panoramique pour afficher une miniature de l'image entière. Vous pouvez ensuite cliquer et faire glisser le curseur pour afficher une vue panoramique de l'image dans votre fenêtre d'image. Au bas de la fenêtre, à côté de la fenêtre indiquant la position du curseur, vous verrez deux champs d'état, puis un bouton Cancel. Le premier champ d'état affiche le nom du fichier, à moins qu'un élément enfichable ne soit en cours d'exécution (par exemple, si vous appliquez un filtre ou un Script-Fu à une image). Si un élément enfichable est en cours d'exécution, son nom s'affiche dans la première fenêtre d'état. Le champ suivant est vide, mais affiche une barre d'état pour un élément enfichable en cours d'exécution. Enfin, le bouton Cancel vous permet d'arrêter un élément enfichable en cours d'exécution. Raccourcis clavier utilesComme de nombreuses autres applications, GIMP facilite l'accomplissement de tâches sans qu'il soit nécessaire d'utiliser la souris. Voici une sélection des raccourcis clavier utiles :
|
|
|