Manpage of RAW
RAW
Section: Linux Programmer's Manual (7)
Updated: 2 Oct 2025
Index
NAME
raw, SOCK_RAW - Linux IPv4 raw sockets
SYNOPSIS
#include <sys/socket.h>
#include <netinet/in.h>
raw_socket = socket(PF_INET, SOCK_RAW, int protocol);
DESCRIPTION
Raw sockets allow new IPv4 protocols to be implemented in user space.
A raw socket receives or sends the raw datagram not including link level headers.
The IPv4 layer generates an IP header when sending a packet unless the
IP_HDRINCL
socket option is enabled on the socket.
When it is enabled, the packet must contain an IP header.
For receiving the IP header is always included in the packet.
Only processes with an effective user id of 0 or the
CAP_NET_RAW
capability are allowed to open raw sockets.
All packets or errors matching the
protocol
number specified
for the raw socket are passed to this socket. For a list of the
allowed protocols see RFC1700 assigned numbers and
A protocol of
IPPROTO_RAW
implies enabled
IP_HDRINCL
and receives all IP protocols. Sending is not allowed.
IP Header fields modified on sending by IP_HDRINCL
|
| IP Checksum | Always filled in.
|
| Source Address | Filled in when zero.
|
| Packet Id | Filled in when zero.
|
| Total Length | Always filled in.
|
If
IP_HDRINCL
is specified and the IP header has a non-zero destination address then
the destination address of the socket is used to route the packet. When
MSG_DONTROUTE
is specified the destination address should refer to a local interface,
otherwise a routing table lookup is done anyways.
If
IP_HDRINCL
isn't set then IP header options can be set on raw sockets with
see
for more information.
In Linux 2.2 all IP header fields and options can be set using
IP socket options. This means raw sockets are only needed for new
protocols or protocols with no user interface (like ICMP). Generating custom
TCP or UDP packets using raw sockets is normally unnecessary.
When a packet is received, it is passed to any raw sockets which have
been bound to its protocol before it is passed to other protocol handlers
(e.g. kernel protocol modules).
ADDRESS FORMAT
Raw sockets use the standard
sockaddr_in
address structure defined in
The
sin_port
field
can be used to specify the IP protocol number,
when it is 0 the protocol specified
in the initial
call is used.
See the
<netinet/in.h>
include file for valid IP protocols.
SOCKET OPTIONS
Raw socket options can be set with
and read with
by passing the
SOL_RAW
family flag.
- ICMP_FILTER
-
Enable a special filter for raw sockets bound to the
IPPROTO_ICMP
protocol. The value has a bit set for each ICMP message type which
should be filtered out. The default is to filter no ICMP messages.
In addition all
SOL_IP
socket options valid for datagram sockets are supported.
NOTES
Raw sockets fragment a packet when its total length exceeds the interface MTU.
A more network friendly and faster alternative is to implement path MTU
discovery as described in the
IP_PMTU_DISCOVER
section of
A raw socket can be bound to a specific local address using the
call. If it isn't bound all packets with the specified IP protocol are received.
In addition a RAW socket can be bound to a specific network device using
SO_BINDTODEVICE;
see
An
IPPROTO_RAW
socket is send only.
If you really want to receive all IP packets use a
socket with the
ETH_P_IP
protocol. Note that packet sockets don't reassemble IP fragments, unlike raw sockets.
If you want to receive all ICMP packets for a datagram socket it is often better
to use
IP_RECVERR
on that particular socket; see
Raw sockets may tap all IP protocols in Linux, even
protocols like ICMP or TCP which have a protocol module in the kernel. In
this case the packets are passed to both the kernel module and the raw
socket(s). This should not be relied upon in portable programs, many other BSD
socket implementation have limitations here.
Linux never changes headers passed from the user (except for filling in some
zeroed fields as described for
IP_HDRINCL).
This differs from many other implementations of raw sockets.
RAW sockets are generally rather unportable and should be avoided in programs
intended to be portable.
ERROR HANDLING
Errors originating from the network are only passed to the user when the
socket is connected or the
IP_RECVERR
flag is enabled. For connected sockets only
EMSGSIZE
and
EPROTO
are passed for compatibility. With
IP_RECVERR
all network errors are saved in the error queue.
ERRORS
- EMSGSIZE
-
Packet too big. Either Path MTU Discovery is enabled (the
IP_PMTU_DISCOVER
socket flag) or the packet size exceeds the maximum allowed IPv4 packet size
of 64KB.
- EACCES
-
User tried to send to a broadcast address without having the broadcast flag
set on the socket.
- EPROTO
-
An ICMP error has arrived reporting a parameter problem.
- EFAULT
-
An invalid memory address was supplied.
- EOPNOTSUPP
-
Invalid flag has been passed to a socket call (like
MSG_OOB).
- EINVAL
-
Invalid argument.
- EPERM
-
The user doesn't have permission to open raw sockets. Only processes
with a effective user id of 0 or the
CAP_NET_RAW
attribute may do that.
VERSIONS
IP_RECVERR
and
ICMP_FILTER
are new in Linux 2.2. They are Linux extensions
and should not be used in portable programs.
Linux 2.0 enabled some bug-to-bug compatibility with BSD in the raw socket code
when the SO_BSDCOMPAT flag was set - that has been removed in 2.2.
BUGS
Transparent proxy extensions are not described.
When the
IP_HDRINCL
option is set datagrams will not be fragmented and are limited to the interface
MTU. This is a limitation in Linux 2.2.
AUTHORS
This man page was writen by Andi Kleen.
SEE ALSO
RFC1191
for path MTU discovery.
RFC791
and the
<linux/ip.h>
include file for the IP protocol.
Index
- NAME
-
- SYNOPSIS
-
- DESCRIPTION
-
- ADDRESS FORMAT
-
- SOCKET OPTIONS
-
- NOTES
-
- ERROR HANDLING
-
- ERRORS
-
- VERSIONS
-
- BUGS
-
- AUTHORS
-
- SEE ALSO
-
This document was created by
using the manual pages.
Time: 12:14:03 GMT, March 24, 2025